summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Patrick McCabe <cmccabe@alumni.cmu.edu>2011-01-23 16:09:14 -0800
committerColin Patrick McCabe <cmccabe@alumni.cmu.edu>2011-01-24 07:44:48 -0800
commitffb208e343b42078ba34a3b5e4d74eff4b8a4d71 (patch)
tree79f01b24064926c216ddf4526b331a3a4d026458 /configure.ac
parent76a1e09a68f782c8d6c6c24eb943e50332d4ad6e (diff)
downloadceph-ffb208e343b42078ba34a3b5e4d74eff4b8a4d71.tar.gz
Makefile: use new Spirit headers where available
Use new boost::spirit header files where available, to eliminate the annoying compiler warning on newer systems. Signed-off-by: Colin McCabe <colin.mccabe@dreamhost.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 8dc66c09a39..4c46b28912d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -154,10 +154,11 @@ AC_HEADER_SYS_WAIT
# spirit?
AC_LANG([C++])
-AC_DEFINE([HAVE_BOOST_SPIRIT_CORE_HPP], [], [Description])
-AC_CHECK_HEADER([boost/spirit.hpp],
- [AC_DEFINE([HAVE_BOOST_SPIRIT_CORE_HPP])],
- [AC_MSG_ERROR([Sorry you need to install the Boost spirit parser library (libboost-dev on debian)])])
+
+AC_CHECK_HEADER([boost/spirit/include/classic_core.hpp], [],
+ [AC_CHECK_HEADER([boost/spirit.hpp], [use_bspirit_old_hdr=yes],
+ AC_MSG_FAILURE(["Can't find boost spirit headers"]))])
+AM_CONDITIONAL(USE_BOOST_SPIRIT_OLD_HDR, [test "$use_bspirit_old_hdr" = "yes"])
AC_LANG([C])