summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2013-01-29 10:31:05 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2013-01-29 10:31:05 +0000
commit74a19c527c1fa07ade2042a8d2acecbb5f6ccab1 (patch)
treea3fc09d007995ff65bb9e51f1176cc42526787f2 /configure.ac
parent41ae904461e344fbfa3be3d276a7102bb4304b19 (diff)
downloadcairo-74a19c527c1fa07ade2042a8d2acecbb5f6ccab1.tar.gz
configure: Include X11.h before testing for usability of Xrender.h
On Solaris at least, the Xrender.h header is not standalone and requires X11/X.h to be included first to define the essential types. Reported-by: Andreas F. Borchert <bugzilla@andreas-borchert.de> Bugzilla; https://bugs.freedesktop.org/show_bug.cgi?id=58199 Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 31123c72b..928a1694d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -136,7 +136,8 @@ CAIRO_ENABLE_SURFACE_BACKEND(xlib_xrender, Xlib Xrender, auto, [
CPPFLAGS="$CPPFLAGS $xlib_CFLAGS $xlib_NONPKGCONFIG_CFLAGS"
AC_CHECK_HEADER(X11/extensions/Xrender.h,
[xlib_xrender_NONPKGCONFIG_LIBS="-lXrender"],
- [use_xlib_xrender="no (requires $xlib_xrender_REQUIRES http://freedesktop.org/Software/xlibs)"])
+ [use_xlib_xrender="no (requires $xlib_xrender_REQUIRES http://freedesktop.org/Software/xlibs)"],
+ [#include <X11/X.h>])
CPPFLAGS=$old_CPPFLAGS
])