summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Shuler <michael@pbandjelly.org>2014-02-23 23:24:02 -0600
committerMichael Shuler <michael@pbandjelly.org>2014-02-23 23:24:02 -0600
commita2c5bfc360164577c4bbf852e85dcb750c1a7c24 (patch)
tree684bdbce1ac7010a4405acb508cc23fd995ba1c2
parent8cefcaf38c45414c96196336e08781cb5ed45be4 (diff)
downloadca-certificates-a2c5bfc360164577c4bbf852e85dcb750c1a7c24.tar.gz
Add trailing newline to certificate, if it is missing (#635570)
-rw-r--r--debian/changelog6
-rwxr-xr-xsbin/update-ca-certificates2
2 files changed, 8 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 562a000..bf7dbf1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+ca-certificates (20140224) UNRELEASED; urgency=medium
+
+ * Add trailing newline to certificate, if it is missing. Closes: #635570
+
+ -- Michael Shuler <michael@pbandjelly.org> Sun, 23 Feb 2014 23:22:29 -0600
+
ca-certificates (20140223) unstable; urgency=medium
* No longer ship cacert.org certificates. Closes: #718434, LP: #1258286
diff --git a/sbin/update-ca-certificates b/sbin/update-ca-certificates
index 28d9a69..aa16771 100755
--- a/sbin/update-ca-certificates
+++ b/sbin/update-ca-certificates
@@ -69,6 +69,8 @@ add() {
ln -sf "$CERT" "$PEM"
echo +$PEM >> "$ADDED"
fi
+ # Add trailing newline to certificate, if it is missing (#635570)
+ sed -i '$a\' "$CERT"
cat "$CERT" >> "$TEMPBUNDLE"
}