summaryrefslogtreecommitdiff
path: root/src/BulletSoftBody/CMakeLists.txt
diff options
context:
space:
mode:
authorerwincoumans <erwin.coumans@gmail.com>2022-03-07 16:35:07 -0800
committerGitHub <noreply@github.com>2022-03-07 16:35:07 -0800
commit4fbecfeddc448eba12da3b38b3449fa6c7a6ec19 (patch)
tree221e6968b52467a0af06695932fe666ad143e986 /src/BulletSoftBody/CMakeLists.txt
parentaee1ab63fe459ad0d6c209cc3c9cffacab2b5854 (diff)
downloadbullet3-4fbecfeddc448eba12da3b38b3449fa6c7a6ec19.tar.gz
Revert "Revert "Reduced Deformable Model""revert-4194-revert-4069-master
Diffstat (limited to 'src/BulletSoftBody/CMakeLists.txt')
-rw-r--r--src/BulletSoftBody/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/BulletSoftBody/CMakeLists.txt b/src/BulletSoftBody/CMakeLists.txt
index 945276801..c12eef5fe 100644
--- a/src/BulletSoftBody/CMakeLists.txt
+++ b/src/BulletSoftBody/CMakeLists.txt
@@ -24,6 +24,11 @@ SET(BulletSoftBody_SRCS
btDeformableMultiBodyDynamicsWorld.cpp
btDeformableContactConstraint.cpp
poly34.cpp
+
+ BulletReducedDeformableBody/btReducedDeformableBody.cpp
+ BulletReducedDeformableBody/btReducedDeformableBodyHelpers.cpp
+ BulletReducedDeformableBody/btReducedDeformableBodySolver.cpp
+ BulletReducedDeformableBody/btReducedDeformableContactConstraint.cpp
)
@@ -63,6 +68,11 @@ SET(BulletSoftBody_HDRS
poly34.h
btSoftBodySolverVertexBuffer.h
+
+ BulletReducedDeformableBody/btReducedDeformableBody.h
+ BulletReducedDeformableBody/btReducedDeformableBodyHelpers.h
+ BulletReducedDeformableBody/btReducedDeformableBodySolver.h
+ BulletReducedDeformableBody/btReducedDeformableContactConstraint.h
)