summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c300d33e9..930c9de40 100755
--- a/setup.py
+++ b/setup.py
@@ -347,7 +347,14 @@ setup(
package_dir={"": "src"},
packages=find_packages(where="src", exclude=("tests", "tests.*")),
package_data={
- "buildstream": ["plugins/*/*.py", "plugins/*/*.yaml", "data/*.yaml", "data/*.sh.in", *list_testing_datafiles()]
+ "buildstream": [
+ "py.typed",
+ "plugins/*/*.py",
+ "plugins/*/*.yaml",
+ "data/*.yaml",
+ "data/*.sh.in",
+ *list_testing_datafiles(),
+ ]
},
data_files=[
# This is a weak attempt to integrate with the user nicely,