diff options
author | Benjamin Schubert <contact@benschubert.me> | 2019-06-05 21:16:50 +0100 |
---|---|---|
committer | bst-marge-bot <marge-bot@buildstream.build> | 2019-06-06 15:53:43 +0000 |
commit | 8f6e36acea77b35f454a53383a94b8fb838957fd (patch) | |
tree | 65a424a26f1e02d2776b2ff3e983cddc4ab34690 /setup.py | |
parent | baec142e623f9e8a4efd93183ac2f7ef15d84b06 (diff) | |
download | buildstream-8f6e36acea77b35f454a53383a94b8fb838957fd.tar.gz |
_loader/types: cimport yaml functions for better speed
- _yaml: export node_validate function as Cython, as it was not done
before. This requires rewriting the function to remove a closure.
- Optimize node check by not calling is_node().
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -399,7 +399,7 @@ def register_cython_module(module_name, dependencies=None): BUILD_EXTENSIONS = [] register_cython_module("buildstream._loader._loader") -register_cython_module("buildstream._loader.types") +register_cython_module("buildstream._loader.types", dependencies=["buildstream._yaml"]) register_cython_module("buildstream._yaml") register_cython_module("buildstream._variables", dependencies=["buildstream._yaml"]) |