summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2017-11-25 18:25:53 +0900
committerTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2017-11-25 18:25:53 +0900
commita6334521433a8a917b82d826f600d854604e9ed7 (patch)
treef47452d4a898d3d16f880ceefdb05b032f58d29d /setup.py
parentf17ef1e47cfce604bcd93373eae9646a96e9122d (diff)
downloadbuildstream-a6334521433a8a917b82d826f600d854604e9ed7.tar.gz
setup.py: Pinning coverage at 4.4.0 instead of 4.2
Our problem is with 4.4.2; and 4.2 lacks some features and fails to collect all of the coverage from sub processes, causing our reports to drop by 10%.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 69a78a1d3..795e8f0cd 100755
--- a/setup.py
+++ b/setup.py
@@ -177,7 +177,7 @@ setup(name='BuildStream',
tests_require=['pep8',
# Pin coverage to 4.2 for now, we're experiencing
# random crashes with 4.4.2
- 'coverage == 4.2',
+ 'coverage == 4.4.0',
'pytest-datafiles',
'pytest-env',
'pytest-pep8',