summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2017-08-27 17:29:08 -0400
committerTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2017-08-28 02:48:07 -0400
commit25caabb2e9ae6548e452eff1bdabeeb23386e1ab (patch)
treec1f03121422368682a4f3df1c82b0d8118c9f82d /setup.py
parent9890d1a8827d894d67f0e3a31b443f13becb1e3b (diff)
downloadbuildstream-25caabb2e9ae6548e452eff1bdabeeb23386e1ab.tar.gz
buildstream/data/bst: Adding a bash completion scriptlet.
Currently this gets installed at ${prefix}/share/bash-completion/completions but this is not exactly correct.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py18
1 files changed, 17 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 80b367cae..a13a06472 100755
--- a/setup.py
+++ b/setup.py
@@ -108,7 +108,23 @@ setup(name='BuildStream',
packages=find_packages(),
package_data={'buildstream': ['plugins/*/*.py', 'plugins/*/*.yaml',
'data/*.yaml', 'data/*.sh.in']},
- data_files=[('share/man/man1', list_man_pages())],
+ data_files=[
+ # This is a weak attempt to integrate with the user nicely,
+ # installing things outside of the python package itself with pip is
+ # not recommended, but there seems to be no standard structure for
+ # addressing this; so just installing this here.
+ #
+ # These do not get installed in developer mode (`pip install --user -e .`)
+ #
+ # The completions are ignored by bash unless it happens to be installed
+ # in the right directory; this is more like a weak statement that we
+ # attempt to install bash completion scriptlet.
+ #
+ ('share/man/man1', list_man_pages()),
+ ('share/bash-completion/completions', [
+ os.path.join('buildstream', 'data', 'bst')
+ ])
+ ],
install_requires=[
'setuptools',
'psutil',