diff options
author | Tristan Van Berkom <tristan.vanberkom@codethink.co.uk> | 2017-06-15 18:40:41 +0900 |
---|---|---|
committer | Tristan Van Berkom <tristan.vanberkom@codethink.co.uk> | 2017-06-15 18:40:41 +0900 |
commit | 0ea7c45f5fea46f1ecf606fdf4090069fb2662b8 (patch) | |
tree | 785ff815f837602b30a02cbc044427ef2ba12b62 /setup.py | |
parent | 85d55ce77ba08e889609f398e7bd8d458397be9a (diff) | |
download | buildstream-0ea7c45f5fea46f1ecf606fdf4090069fb2662b8.tar.gz |
setup.py: Added comment about OSTree.YEAR_VERSION & OSTree.RELEASE_VERSION
We can start using those to assert the version >= 2017.4
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 7 |
1 files changed, 7 insertions, 0 deletions
@@ -46,6 +46,13 @@ except ImportError: # We require at least v2016.8 of OSTree, which contain the # fixes in this bug: # https://github.com/ostreedev/ostree/pull/417 +# +# Note: As of ostree v2017.4, we can use the symbols: +# OSTree.YEAR_VERSION +# OSTree.RELEASE_VERSION +# +# Directly, to make checks on the version, if we have +# a version which lacks these symbols, then it is < v2017.4 ################################################################## def exit_ostree(reason): print(reason + ": BuildStream requires OSTree >= v2016.8 with Python bindings. " |