diff options
author | William Salmon <will.salmon@codethink.co.uk> | 2019-06-05 14:22:34 +0100 |
---|---|---|
committer | bst-marge-bot <marge-bot@buildstream.build> | 2019-07-12 06:57:52 +0000 |
commit | 33272aa7764c03f7d0b3a7b36f08636f883c3e69 (patch) | |
tree | 675034c2720fdf2fd80a3d6da29b77fab15e414e /setup.py | |
parent | 24426ebe31fc2ad297b352a1d332c7cf158ef5c2 (diff) | |
download | buildstream-33272aa7764c03f7d0b3a7b36f08636f883c3e69.tar.gz |
Refactor of Platform and Sandbox
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 6 |
1 files changed, 5 insertions, 1 deletions
@@ -84,8 +84,12 @@ def bwrap_too_old(major, minor, patch): def check_for_bwrap(): - platform = os.environ.get('BST_FORCE_BACKEND', '') or sys.platform + platform = sys.platform + if platform.startswith('linux'): + sandbox = os.environ.get('BST_FORCE_SANDBOX', "bwrap") + if sandbox != 'bwrap': + return bwrap_path = shutil.which('bwrap') if not bwrap_path: warn_bwrap("Bubblewrap not found") |