summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2016-11-14 22:10:45 +0900
committerTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2016-11-14 22:16:47 +0900
commit38c1442612c1aed3ebcfe51f65f036cbe5f18055 (patch)
tree54cd5fd9e222d1892de7e7cf747c7cb2e08a2c47 /setup.py
parent6a493341d56aa348bc94bc0cdd84413831d26691 (diff)
downloadbuildstream-38c1442612c1aed3ebcfe51f65f036cbe5f18055.tar.gz
Adding InvocationContext
An object for collecting user preferences from config files and command line, this state is shared across recursive pipelines. Also adds the default configuration file and ensures that it's distributed into a data subdir.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 884ebf97c..5dc806079 100755
--- a/setup.py
+++ b/setup.py
@@ -31,7 +31,7 @@ setup(name='buildstream',
description='A framework for modelling build pipelines in YAML',
license='LGPL',
packages=find_packages(),
- package_data={'buildstream': ['plugins/*/*.py']},
+ package_data={'buildstream': ['plugins/*/*.py', 'data/*.yaml']},
scripts=['bin/build-stream'],
install_requires=[
'ruamel.yaml',