summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2017-03-08 16:50:28 +0900
committerTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2017-03-08 16:50:28 +0900
commite91c1d598b768175f5471d736afa226e03027b7a (patch)
treedbc9c4f7293d5a2fd90e9c148a7927ffc7e4ba8a /setup.py
parentf34a0e1aafd094072e9c915ea12f892ebe98065b (diff)
downloadbuildstream-e91c1d598b768175f5471d736afa226e03027b7a.tar.gz
setup.py: Added setuptools as install requirement
This is redundant in cases where setuptools is used to install, but is pedantically correct since we use setuptools in BuildStream to detect and print the package version.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 53319cecd..7160786ce 100755
--- a/setup.py
+++ b/setup.py
@@ -71,13 +71,14 @@ except AttributeError:
exit_ostree("OSTree too old")
-setup(name='buildstream',
+setup(name='BuildStream',
version='0.1',
description='A framework for modelling build pipelines in YAML',
license='LGPL',
packages=find_packages(),
package_data={'buildstream': ['plugins/*/*.py', 'plugins/*/*.yaml', 'data/*.yaml']},
install_requires=[
+ 'setuptools',
'psutil',
'ruamel.yaml',
'pluginbase',