diff options
author | Chandan Singh <csingh43@bloomberg.net> | 2018-06-30 03:31:17 +0100 |
---|---|---|
committer | Chandan Singh <csingh43@bloomberg.net> | 2018-08-22 00:47:32 +0100 |
commit | ab1caac195d1f136c4bb0150cc500ba6d3504a75 (patch) | |
tree | 28cb48d7ba3f9318b280cdf3517a00cc69276ef8 /setup.py | |
parent | d8256c74e3485d17d56f027c51ccf2c7100ac754 (diff) | |
download | buildstream-ab1caac195d1f136c4bb0150cc500ba6d3504a75.tar.gz |
setup.py: Add fields required for publishing on PyPichandan/pypi-prep
Fill out those fields in `setup.py` that are required for publishing a
package on PyPi.
Part of https://gitlab.com/BuildStream/buildstream/issues/587.
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 12 |
1 files changed, 12 insertions, 0 deletions
@@ -224,6 +224,13 @@ def get_cmdclass(): with open('dev-requirements.txt') as dev_reqs: dev_requires = dev_reqs.read().splitlines() +##################################################### +# Prepare package description from README # +##################################################### +with open(os.path.join(os.path.dirname(os.path.realpath(__file__)), + 'README.rst')) as readme: + long_description = readme.read() + ##################################################### # Main setup() Invocation # @@ -233,8 +240,13 @@ setup(name='BuildStream', version=versioneer.get_version(), cmdclass=get_cmdclass(), + author='BuildStream Developers', + author_email='buildstream-list@gnome.org', description='A framework for modelling build pipelines in YAML', license='LGPL', + long_description=long_description, + long_description_content_type='text/x-rst; charset=UTF-8', + url='https://gitlab.com/BuildStream/buildstream', packages=find_packages(exclude=('tests', 'tests.*')), package_data={'buildstream': ['plugins/*/*.py', 'plugins/*/*.yaml', 'data/*.yaml', 'data/*.sh.in']}, |