diff options
author | Jürg Billeter <j@bitron.ch> | 2020-04-02 07:49:45 +0200 |
---|---|---|
committer | Jürg Billeter <j@bitron.ch> | 2020-04-02 08:06:23 +0200 |
commit | 8b6cc681bf1fd0857f2155c160607faaff5eda98 (patch) | |
tree | 27d749214a3f585258014ba216a6482a58c7bb96 /setup.py | |
parent | 2c09f55354ec6f96017e99ffdb94a5e4e99e5694 (diff) | |
download | buildstream-8b6cc681bf1fd0857f2155c160607faaff5eda98.tar.gz |
setup.py: Require Python >= 3.6
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 6 |
1 files changed, 3 insertions, 3 deletions
@@ -35,10 +35,10 @@ import versioneer # noqa # Python requirements ################################################################## REQUIRED_PYTHON_MAJOR = 3 -REQUIRED_PYTHON_MINOR = 5 +REQUIRED_PYTHON_MINOR = 6 if sys.version_info[0] != REQUIRED_PYTHON_MAJOR or sys.version_info[1] < REQUIRED_PYTHON_MINOR: - print("BuildStream requires Python >= 3.5") + print("BuildStream requires Python >= 3.6") sys.exit(1) try: @@ -333,9 +333,9 @@ setup(name='BuildStream', 'License :: OSI Approved :: GNU Lesser General Public License v2 or later (LGPLv2+)', 'Operating System :: POSIX', 'Programming Language :: Python :: 3', - 'Programming Language :: Python :: 3.5', 'Programming Language :: Python :: 3.6', 'Programming Language :: Python :: 3.7', + 'Programming Language :: Python :: 3.8', 'Topic :: Software Development :: Build Tools' ], description='A framework for modelling build pipelines in YAML', |