summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2016-12-09 21:14:00 +0900
committerTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2016-12-09 21:14:00 +0900
commit63ca7ee8334c00771a6c1e833d40659c3057e3a3 (patch)
tree448781d44176dd0ab699a6aeb083673b9a1ba6ce /setup.py
parentaee302aae6536355f567541c49a618d3c53c7146 (diff)
downloadbuildstream-63ca7ee8334c00771a6c1e833d40659c3057e3a3.tar.gz
Add pep8 checks to test suite
Now when running ./setup.py test, pep8 linter checks are automatically run.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c56624e93..80f64d08c 100755
--- a/setup.py
+++ b/setup.py
@@ -56,5 +56,8 @@ setup(name='buildstream',
'argparse'
],
setup_requires=['pytest-runner'],
- tests_require=['pytest-datafiles', 'pytest'],
+ tests_require=['pep8',
+ 'pytest-datafiles',
+ 'pytest-pep8',
+ 'pytest'],
zip_safe=False)