summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2016-12-30 14:56:07 -0500
committerTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2016-12-31 17:39:09 -0500
commit5b0d7e592bea00e4d6b0eb37d9d865ab29b1d550 (patch)
tree20289c82f99600845f1fa274ff9f7b7252a97327 /setup.py
parentd7f1e1913298b705e7e1de9d2572ba50e3464db9 (diff)
downloadbuildstream-5b0d7e592bea00e4d6b0eb37d9d865ab29b1d550.tar.gz
setup.py: Finally use click for this, not argparse
Click is a nicer command line parser tool than argparse.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index bd94764a4..32a708c78 100755
--- a/setup.py
+++ b/setup.py
@@ -57,7 +57,7 @@ setup(name='buildstream',
install_requires=[
'ruamel.yaml',
'pluginbase',
- 'argparse'
+ 'click'
],
setup_requires=['pytest-runner'],
tests_require=['pep8',