summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2016-11-06 15:36:19 +0900
committerTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2016-11-08 18:17:47 +0900
commit05e6608b01738491b83c5e10614bccaf9bed1aaf (patch)
tree4b3baa2a82128bbe158cbc68e1e349148c1c8c45 /setup.py
parentdd8b1d8c52538d71e99be6fb4f16b5b391ad1091 (diff)
downloadbuildstream-05e6608b01738491b83c5e10614bccaf9bed1aaf.tar.gz
Adding initial setup.py file for setuptools.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py19
1 files changed, 19 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000..990ea4690
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,19 @@
+from setuptools import setup
+from setuptools import find_packages
+
+setup(name='buildstream',
+ version='0.1',
+ description='Framework for modelling of build pipelines in YAML',
+ license='LGPL',
+ packages=find_packages(),
+ scripts=['bin/build-stream'],
+ install_requires=[
+
+ # Dependencies for the buildstream library
+ 'ruamel.yaml',
+ 'pluginbase',
+
+ # Dependencies for the CLI frontend only
+ 'argparse'
+ ],
+ zip_safe=False)