summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2016-12-11 12:38:46 +0900
committerTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2016-12-11 12:38:46 +0900
commit0352968cffd8cf03ff1d3509c28665d9f8e60c5c (patch)
tree210cf38751d7f90fb825aa025ba92bfc2dfcb0b8 /setup.py
parent54551b1f049c5576c3d26b9e0d07a14f545d34af (diff)
downloadbuildstream-0352968cffd8cf03ff1d3509c28665d9f8e60c5c.tar.gz
Include coverage report in ./setup.py test invocations
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 80f64d08c..c776a217a 100755
--- a/setup.py
+++ b/setup.py
@@ -57,7 +57,9 @@ setup(name='buildstream',
],
setup_requires=['pytest-runner'],
tests_require=['pep8',
+ 'coverage',
'pytest-datafiles',
'pytest-pep8',
+ 'pytest-cov',
'pytest'],
zip_safe=False)