diff options
author | Benjamin Schubert <ben.c.schubert@gmail.com> | 2019-06-04 10:23:48 +0100 |
---|---|---|
committer | bst-marge-bot <marge-bot@buildstream.build> | 2019-06-05 15:15:23 +0000 |
commit | b2b740167cfb5f4359aecbf114deb5ff1af73b04 (patch) | |
tree | 299d3644228df9dc1ef104e13eee46543b485380 /setup.py | |
parent | 246571606853aef6da856d778f783b14339a2cea (diff) | |
download | buildstream-b2b740167cfb5f4359aecbf114deb5ff1af73b04.tar.gz |
_loader/loader: cythonize valid_chars_name
- Create a new _loader/utils.pyx cython module for functions cythonized
in the loader module.
- Move valid_chars_name from loader to utils and cythonize.
This function is called extensively, and easy to extract
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 1 |
1 files changed, 1 insertions, 0 deletions
@@ -398,6 +398,7 @@ def register_cython_module(module_name, dependencies=None): BUILD_EXTENSIONS = [] +register_cython_module("buildstream._loader._loader") register_cython_module("buildstream._yaml") register_cython_module("buildstream._variables", dependencies=["buildstream._yaml"]) |