diff options
author | Javier Jardón <jjardon@gnome.org> | 2018-08-12 04:10:27 +0100 |
---|---|---|
committer | Javier Jardón <jjardon@gnome.org> | 2018-08-12 04:37:04 +0100 |
commit | 1819a288eb8302cc09ab21156e889280cff9806f (patch) | |
tree | ee87a4ccfec346c0b757b7bcc69919617342533a /setup.py | |
parent | 2f27d428f545af3f967d71c6ee9bb7df07b7d005 (diff) | |
download | buildstream-1819a288eb8302cc09ab21156e889280cff9806f.tar.gz |
dev-requirements.txt: Remove obsolete comments
This also fixes an error with pylint in setup.py:
setup.py:226:19: R1718: Consider using a set comprehension (consider-using-set-comprehension)
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 8 |
1 files changed, 3 insertions, 5 deletions
@@ -221,10 +221,8 @@ def get_cmdclass(): ##################################################### # Gather requirements # ##################################################### -setup_requires = set(['pytest-runner']) with open('dev-requirements.txt') as dev_reqs: - dev_requires = set([line for line in dev_reqs.read().split('\n') - if not line.strip().startswith('#')]) + dev_requires = dev_reqs.read().splitlines() ##################################################### @@ -269,6 +267,6 @@ setup(name='BuildStream', 'grpcio >= 1.10', ], entry_points=bst_install_entry_points, - setup_requires=list(setup_requires), - tests_require=list(dev_requires - setup_requires), + setup_requires=['pytest-runner'], + tests_require=dev_requires, zip_safe=False) |