diff options
author | Daniel Playle <dplayle@bloomberg.net> | 2018-06-18 13:26:41 +0100 |
---|---|---|
committer | Tristan Van Berkom <tristan.van.berkom@gmail.com> | 2018-06-20 22:05:19 +0000 |
commit | 4f168b9b6a02216e2fae24d758ae6b778e545869 (patch) | |
tree | 4136d4a3aedb8e16387dd1a2d26be718799e9ee7 /setup.py | |
parent | 4016bec1d747481ca8354c1c798fba0271d4696b (diff) | |
download | buildstream-4f168b9b6a02216e2fae24d758ae6b778e545869.tar.gz |
Restrict version of pylint138-aborting-bst-push-command-causes-stack-trace-2
pylint >2 is not compatible with pytest_pylint in its current form. As
such, allowing any version of pylint for testing results in a failure.
This commit restricts down the allowable versions of pylint to those
that are both compatible with pytest_pylint, and also offer the feature
set that we require.
See https://gitlab.com/BuildStream/buildstream/issues/427 for further
details.
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -257,5 +257,6 @@ setup(name='BuildStream', 'pytest-cov', # Provide option to run tests in parallel, less reliable 'pytest-xdist', - 'pytest >= 3.1.0'], + 'pytest >= 3.1.0', + 'pylint >= 1.8 , < 2'], zip_safe=False) |