summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2017-03-18 19:06:54 +0900
committerTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2017-03-20 10:01:25 +0000
commit8a423b95cf6c674dde35f9998e549cb3ae08a215 (patch)
treef59f9df88f3ad03ec401d3af8a0f78364efb71fd /setup.py
parentda394300561d4fd65eb238152f1ced15d2a41dbe (diff)
downloadbuildstream-8a423b95cf6c674dde35f9998e549cb3ae08a215.tar.gz
context.py: Now using the XDG Base Directory spec
o Attempt to load user configuration from ${XDG_CONFIG_HOME}/buildstream.conf if one exists, only if not overridden on the command line o Set the XDG Base Directory values at initialization time o Allow environment vars to be specified in paths o userconfig.yaml: Default paths now use XDG_CACHE_HOME instead of ~/buildstream o Removed the deploydir and ccache dir as we're not using those, we'll re-add those configs if they become relevant.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7160786ce..5a0b121d8 100755
--- a/setup.py
+++ b/setup.py
@@ -79,6 +79,7 @@ setup(name='BuildStream',
package_data={'buildstream': ['plugins/*/*.py', 'plugins/*/*.yaml', 'data/*.yaml']},
install_requires=[
'setuptools',
+ 'xdg',
'psutil',
'ruamel.yaml',
'pluginbase',