summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2016-12-30 15:46:47 -0500
committerTristan Van Berkom <tristan.vanberkom@codethink.co.uk>2016-12-31 17:39:09 -0500
commit15a5b007e63ce83bd28064be5c3b516836ba7cdb (patch)
tree5ea8262ce056570cfb20456e2b56da2e9e86b6dc /setup.py
parent5b0d7e592bea00e4d6b0eb37d9d865ab29b1d550 (diff)
downloadbuildstream-15a5b007e63ce83bd28064be5c3b516836ba7cdb.tar.gz
Moved frontend into buildstream package and build pipeline, use click.
Use setuptools to create the actual frontend script automatically, keeping the frontend code inside the package just makes things easier.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 32a708c78..64c330e18 100755
--- a/setup.py
+++ b/setup.py
@@ -53,12 +53,15 @@ setup(name='buildstream',
license='LGPL',
packages=find_packages(),
package_data={'buildstream': ['plugins/*/*.py', 'plugins/*/*.yaml', 'data/*.yaml']},
- scripts=['bin/build-stream'],
install_requires=[
'ruamel.yaml',
'pluginbase',
- 'click'
+ 'Click'
],
+ entry_points='''
+ [console_scripts]
+ build-stream=buildstream._main:cli
+ ''',
setup_requires=['pytest-runner'],
tests_require=['pep8',
'coverage',