summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am24
1 files changed, 8 insertions, 16 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 494a9c2d4..df950f8ef 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -8,30 +8,22 @@ if HID2HCI
rules_DATA += bluetooth-hid2hci.rules
endif
-if PCMCIARULES
+if PCMCIA
rules_DATA += bluetooth-serial.rules
endif
+
+if UDEVRULES
+rules_DATA += bluetooth.rules
+endif
endif
-if PCMCIARULES
+if PCMCIA
udevdir = $(libexecdir)/udev
udev_SCRIPTS = bluetooth_serial
endif
-EXTRA_DIST = bluetooth.init bluetooth.default bluetooth-hid2hci.rules \
- bluetooth-serial.rules bluetooth_serial
+EXTRA_DIST = bluetooth.init bluetooth.default bluetooth.rules \
+ bluetooth-hid2hci.rules bluetooth-serial.rules bluetooth_serial
MAINTAINERCLEANFILES = Makefile.in
-
-if INITSCRIPTS
-install-data-local:
- $(INSTALL) -D -m 755 $(srcdir)/bluetooth.init $(DESTDIR)$(sysconfdir)/init.d/bluetooth
- $(mkinstalldirs) $(DESTDIR)$(sysconfdir)/default
- [ -f $(DESTDIR)$(sysconfdir)/default/bluetooth ] || \
- $(INSTALL_DATA) $(srcdir)/bluetooth.default $(DESTDIR)$(sysconfdir)/default/bluetooth
-
-uninstall-local:
- @rm -f $(DESTDIR)$(sysconfdir)/init.d/bluetooth
- @rm -f $(DESTDIR)$(sysconfdir)/default/bluetooth
-endif