summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorVinicius Costa Gomes <vinicius.gomes@openbossa.org>2010-07-22 19:28:28 -0300
committerJohan Hedberg <johan.hedberg@nokia.com>2010-08-09 18:06:45 -0400
commitdb86285382d4ca172eeef36fdc4d7d26c8e64b0a (patch)
tree70fc0025da11c3841ec06e2bb1db6331e0e2fc2b /Makefile.am
parent2581dc90f0dd3e3a15964efba6aeda2f958b5db2 (diff)
downloadbluez-db86285382d4ca172eeef36fdc4d7d26c8e64b0a.tar.gz
Fix attrib files being compiled only for the plugin
Now as attrib is part of the core bluetoothd, it should be included as part of the core.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index cfec7a850..350f33a8d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -173,7 +173,7 @@ endif
if ATTRIBPLUGIN
builtin_modules += attrib
-builtin_sources += $(attrib_sources) attrib/main.c \
+builtin_sources += attrib/main.c \
attrib/manager.h attrib/manager.c \
attrib/client.h attrib/client.c \
attrib/example.h attrib/example.c
@@ -196,6 +196,7 @@ endif
sbin_PROGRAMS += src/bluetoothd
src_bluetoothd_SOURCES = $(gdbus_sources) $(builtin_sources) \
+ $(attrib_sources) \
src/main.c src/log.h src/log.c \
src/security.c src/rfkill.c src/hcid.h src/sdpd.h \
src/sdpd-server.c src/sdpd-request.c \
@@ -333,7 +334,8 @@ AM_CFLAGS = @DBUS_CFLAGS@ @GLIB_CFLAGS@ @CAPNG_CFLAGS@ \
-DBLUETOOTH_PLUGIN_BUILTIN -DPLUGINDIR=\""$(plugindir)"\"
INCLUDES = -I$(builddir)/lib -I$(builddir)/src -I$(srcdir)/src \
- -I$(srcdir)/audio -I$(srcdir)/sbc -I$(srcdir)/gdbus
+ -I$(srcdir)/audio -I$(srcdir)/sbc -I$(srcdir)/gdbus \
+ -I$(srcdir)/attrib
pkgconfigdir = $(libdir)/pkgconfig