summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLucas De Marchi <lucas.demarchi@profusion.mobi>2010-09-21 15:46:56 -0300
committerJohan Hedberg <johan.hedberg@nokia.com>2010-09-21 23:08:57 +0300
commit534be7a9c3af97172869da2baac23ae019fd69a5 (patch)
tree20f418b5faecd86f3ccf4cb168b634d944c267a0 /Makefile.am
parentce86aba22dc3a2b346cfa8d93d3b343523dd4445 (diff)
downloadbluez-534be7a9c3af97172869da2baac23ae019fd69a5.tar.gz
Simplify linker script
Version linker scripts support function names and globs, so there's no need to rely on nm tool to gather the exported symbols.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 1 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index 05bc8fc76..1c70e5d5d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -258,7 +258,7 @@ builtin_files = src/builtin.h $(builtin_nodist)
nodist_src_bluetoothd_SOURCES = $(builtin_files)
-CLEANFILES += src/bluetooth.ver src/bluetooth.exp $(builtin_files)
+CLEANFILES += $(builtin_files)
man_MANS = src/bluetoothd.8
@@ -392,18 +392,6 @@ src/plugin.$(OBJEXT): src/builtin.h
src/builtin.h: src/genbuiltin $(builtin_sources)
$(AM_V_GEN)$(srcdir)/src/genbuiltin $(builtin_modules) > $@
-src/bluetooth.exp: $(src_bluetoothd_OBJECTS)
- $(AM_V_GEN)$(NM) $^ | $(AWK) '{ print $$3 }' | sort -u | \
- $(EGREP) -e '^btd_' -e '^g_dbus_' > $@
- $(AM_V_at)echo -e "info" >> $@
- $(AM_V_at)echo -e "error" >> $@
- $(AM_V_at)echo -e "debug" >> $@
-
-src/bluetooth.ver: src/bluetooth.exp
- $(AM_V_at)echo "{ global:" > $@
- $(AM_V_GEN)$(SED) -e "s/\(.*\)/\1;/" $< >> $@
- $(AM_V_at)echo "local: *; };" >> $@
-
audio/telephony.c: audio/@TELEPHONY_DRIVER@
$(AM_V_GEN)$(LN_S) $(abs_top_srcdir)/$< $@