summaryrefslogtreecommitdiff
path: root/sim/erc32/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'sim/erc32/configure.ac')
-rw-r--r--sim/erc32/configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/sim/erc32/configure.ac b/sim/erc32/configure.ac
index 3135dc55ec8..e4df81989cb 100644
--- a/sim/erc32/configure.ac
+++ b/sim/erc32/configure.ac
@@ -26,12 +26,11 @@ AC_CACHE_CHECK([for cygwin], sim_cv_os_cygwin,
lose
#endif],[sim_cv_os_cygwin=yes],[sim_cv_os_cygwin=no])])
+# Keep in sync with gdb's configure.ac list.
+AC_SEARCH_LIBS(tgetent, [termcap tinfo curses ncurses],
+ [TERMCAP=$ac_cv_search_tgetent], [TERMCAP=""])
if test x$sim_cv_os_cygwin = xyes; then
- TERMCAP='`if test -r ../../libtermcap/libtermcap.a; then echo ../../libtermcap/libtermcap.a; else echo -ltermcap; fi` -luser32'
-else
- # Keep in sync with gdb's configure.ac list.
- AC_SEARCH_LIBS(tgetent, [termcap tinfo curses ncurses],
- [TERMCAP=$ac_cv_search_tgetent], [TERMCAP=""])
+ TERMCAP="${TERMCAP} -luser32"
fi
AC_SUBST(TERMCAP)