summaryrefslogtreecommitdiff
path: root/sim/cris/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'sim/cris/configure.ac')
-rw-r--r--sim/cris/configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/sim/cris/configure.ac b/sim/cris/configure.ac
new file mode 100644
index 00000000000..a34a50bae8b
--- /dev/null
+++ b/sim/cris/configure.ac
@@ -0,0 +1,22 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_PREREQ(2.59)dnl
+AC_INIT(Makefile.in)
+AC_CONFIG_HEADER(config.h:config.in)
+
+sinclude(../common/aclocal.m4)
+
+# Bugs in autoconf 2.59 break the call to SIM_AC_COMMON, hack around
+# it by inlining the macro's contents.
+sinclude(../common/common.m4)
+
+SIM_AC_OPTION_ALIGNMENT(NONSTRICT_ALIGNMENT)
+SIM_AC_OPTION_HOSTENDIAN
+SIM_AC_OPTION_SCACHE(16384)
+
+# The default model shouldn't matter as long as there's a BFD.
+SIM_AC_OPTION_DEFAULT_MODEL(crisv32)
+SIM_AC_OPTION_ENVIRONMENT
+SIM_AC_OPTION_INLINE()
+SIM_AC_OPTION_CGEN_MAINT
+
+SIM_AC_OUTPUT