summaryrefslogtreecommitdiff
path: root/sim/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'sim/configure.in')
-rw-r--r--sim/configure.in9
1 files changed, 4 insertions, 5 deletions
diff --git a/sim/configure.in b/sim/configure.in
index d576bcebdd9..d6fa7bab3fa 100644
--- a/sim/configure.in
+++ b/sim/configure.in
@@ -3,7 +3,7 @@
# appropriate for this directory. For more information, check any
# existing configure script.
-configdirs="h8300 z8k"
+configdirs="h8300 z8k h8500"
srctrigger=Makefile.in
srcname="sim"
target_dependent=true
@@ -20,16 +20,15 @@ target_dependent=true
case "${target}" in
h8300-*-*) sim_target=h8300 ;;
+ h8500-*-*) sim_target=h8500 ;;
z8k*-*-*) sim_target=z8k ;;
+ *) sim_target=none ;;
esac
configdirs=${sim_target}
if [ ! -f ${srcdir}/${sim_target}/${sim_target}.mt ] ; then
- if [ -n "${sim_target}" ] ; then
- echo '***' No file ${srcdir}/${sim_target}/${sim_target}.mt 1>&2
- fi
- echo '***' The simulator does not support target ${target} 1>&2
+target_makefile_frag=
else
target_makefile_frag=${sim_target}/${sim_target}.mt
fi