summaryrefslogtreecommitdiff
path: root/readline/examples/rlfe/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'readline/examples/rlfe/configure.in')
-rw-r--r--readline/examples/rlfe/configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/readline/examples/rlfe/configure.in b/readline/examples/rlfe/configure.in
index 108cd3f50e3..ad7ce65fc06 100644
--- a/readline/examples/rlfe/configure.in
+++ b/readline/examples/rlfe/configure.in
@@ -1,7 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-m4_include([../../../config/override.m4])
-
AC_INIT(rlfe.c)
AC_CONFIG_HEADER(config.h)
VERSION=0.4
@@ -225,6 +223,7 @@ AC_TRY_LINK(,tgetent((char *)0, (char *)0);,,
AC_MSG_ERROR(!!! no tgetent - no screen))))))
AC_TRY_RUN([
+extern char *tgoto();
main()
{
exit(strcmp(tgoto("%p1%d", 0, 1), "1") ? 0 : 1);
@@ -437,6 +436,7 @@ main()
fi
-AC_CHECK_HEADERS(sys/stropts.h sys/wait.h)
+AC_CHECK_HEADERS(sys/stropts.h sys/wait.h sgtty.h sys/select.h)
+AC_CHECK_HEADERS(term.h)
AC_OUTPUT(Makefile)