summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index d2b75f63752..96e0a7b79bc 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -1593,6 +1593,11 @@ if test ${build} = ${host} -a ${host} = ${target} ; then
CONFIG_SRCS="${CONFIG_SRCS} aix-thread.c"
CONFIG_OBS="${CONFIG_OBS} aix-thread.o"
CONFIG_LDFLAGS="${CONFIG_LDFLAGS} -lpthdebug"
+
+ # Older versions of AIX do not provide the declaration for
+ # the getthrds function (it appears that it was introduced
+ # with AIX 6.x).
+ AC_CHECK_DECLS(getthrds, [], [], [[#include <procinfo.h>]])
fi
;;
esac