summaryrefslogtreecommitdiff
path: root/gas/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gas/doc/Makefile.am')
-rw-r--r--gas/doc/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/gas/doc/Makefile.am b/gas/doc/Makefile.am
index 5dc43b6693d..4c6816b9ee1 100644
--- a/gas/doc/Makefile.am
+++ b/gas/doc/Makefile.am
@@ -71,6 +71,20 @@ CPU_DOCS = \
# cygnus option.
install-data-local: install-info
+pdf__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
+
+install-pdf: install-pdf-am
+
+install-pdf-am: $(PDFS)
+ @$(NORMAL_INSTALL)
+ test -z "$(pdfdir)" || $(mkinstalldirs) "$(DESTDIR)$(pdfdir)"
+ @list='$(PDFS)'; for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ f=$(pdf__strip_dir) \
+ echo " $(INSTALL_DATA) '$$d$$p' '$(DESTDIR)$(pdfdir)/$$f'"; \
+ $(INSTALL_DATA) "$$d$$p" "$(DESTDIR)$(pdfdir)/$$f"; \
+ done
+
html__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
install-html: install-html-am