summaryrefslogtreecommitdiff
path: root/binutils/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'binutils/configure.in')
-rw-r--r--binutils/configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/binutils/configure.in b/binutils/configure.in
index 0d037428c9c..978fb81f0a7 100644
--- a/binutils/configure.in
+++ b/binutils/configure.in
@@ -44,6 +44,13 @@ AM_BINUTILS_WARNINGS
AC_CONFIG_HEADERS(config.h:config.in)
+AH_VERBATIM([00_CONFIG_H_CHECK],
+[/* Check that config.h is #included before system headers
+ (this works only for glibc, but that should be enough). */
+#if defined(__GLIBC__)
+# error config.h must be #included before system headers
+#endif])
+
if test -z "$target" ; then
AC_MSG_ERROR(Unrecognized target system type; please check config.sub.)
fi