summaryrefslogtreecommitdiff
path: root/gold/configure.ac
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>2013-10-11 22:07:40 +0000
committerRoland McGrath <roland@gnu.org>2013-10-11 22:07:40 +0000
commit13323c494d81ee60a3d1b050f0ee29ecbbfae26a (patch)
tree42a05e8286771d20c7092f0e808201b6651e5266 /gold/configure.ac
parent1496b4465d0f01843fd6e2e20b1d70f42359c223 (diff)
downloadbinutils-gdb-13323c494d81ee60a3d1b050f0ee29ecbbfae26a.tar.gz
gold/
* configure.ac (TLS_GNU2_DIALECT): Use -Werror in test. (HAVE_PUBNAMES): Likewise. * configure: Regenerate.
Diffstat (limited to 'gold/configure.ac')
-rw-r--r--gold/configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/gold/configure.ac b/gold/configure.ac
index 4cc9569e12f..c23117b6e75 100644
--- a/gold/configure.ac
+++ b/gold/configure.ac
@@ -389,8 +389,13 @@ fi
AM_CONDITIONAL(OMP_SUPPORT, test "$gold_cv_c_threadprivate" = "yes")
dnl Test for the -ftls-dialect=gnu2 option.
+dnl Use -Werror in case of compilers that make unknown -m options warnings.
+dnl They would pass the test here, but fail in actual use when $WARN_CFLAGS
+dnl gets set later by default Autoconf magic to include -Werror. (We are
+dnl assuming here that there is no compiler that groks -mtls-dialect=gnu2
+dnl but does not grok -Werror.)
save_CFLAGS="$CFLAGS"
-CFLAGS="$CFLAGS -fpic -mtls-dialect=gnu2"
+CFLAGS="$CFLAGS -Werror -fpic -mtls-dialect=gnu2"
AC_COMPILE_IFELSE([
__thread int i;
void foo (void)
@@ -592,8 +597,13 @@ if test "$gold_cv_stat_st_mtim" = "yes"; then
fi
dnl Check if gcc supports the -gpubnames option.
+dnl Use -Werror in case of compilers that make unknown -g options warnings.
+dnl They would pass the test here, but fail in actual use when $WARN_CFLAGS
+dnl gets set later by default Autoconf magic to include -Werror. (We are
+dnl assuming here that there is no compiler that groks -gpubnames
+dnl but does not grok -Werror.)
save_CXXFLAGS="$CXXFLAGS"
-CXXFLAGS="$CXXFLAGS -gpubnames"
+CXXFLAGS="$CXXFLAGS -Werror -gpubnames"
AC_COMPILE_IFELSE([int i;], [have_pubnames=yes], [have_pubnames=no])
CXXFLAGS="$save_CXXFLAGS"
AM_CONDITIONAL(HAVE_PUBNAMES, test "$have_pubnames" = "yes")