summaryrefslogtreecommitdiff
path: root/gdb/configure.in
diff options
context:
space:
mode:
authorAndrew Cagney <cagney@redhat.com>2000-03-03 02:50:24 +0000
committerAndrew Cagney <cagney@redhat.com>2000-03-03 02:50:24 +0000
commit379d643457e5153e55698eb6e0cac2773077ae2b (patch)
treeb2e30b97c153922fe8a5057b583296ecffa77c93 /gdb/configure.in
parent7b64ac2f7a844dfe56b6930622bd8847b628f501 (diff)
downloadbinutils-gdb-379d643457e5153e55698eb6e0cac2773077ae2b.tar.gz
Only configure GDBtk when it is present.
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in11
1 files changed, 5 insertions, 6 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index 06587ebaaa0..c12bdae22a1 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -576,8 +576,6 @@ AC_DEFINE_UNQUOTED(TARGET_CPU_DEFAULT, "${with_cpu}")
],)
-ENABLE_GDBTK=
-
AC_ARG_ENABLE(gdbtk,
[ --enable-gdbtk Enable GDBTK GUI front end],
[case "${enableval}" in
@@ -603,8 +601,11 @@ case "$host" in
*go32* | *windows*)
;;
*)
- enable_gdbtk=yes ;;
- esac
+ if test -d "${srcdir}/gdbtk" ; then
+ enable_gdbtk=yes
+ fi
+ ;;
+esac
])
WIN32LDAPP=
@@ -677,7 +678,6 @@ if test "${enable_gdbtk}" = "yes"; then
TIX_DEPS="${TIX_BUILD_LOCATION}/${TIX_LIB_FILE}"
fi
- ENABLE_GDBTK=1
ENABLE_CFLAGS="$ENABLE_CFLAGS -DGDBTK"
# Tcl/Tk 8.1 require -fwritable strings. I don't
# know whether 8.2 will or not, but I bet it will.
@@ -713,7 +713,6 @@ if test "${enable_gdbtk}" = "yes"; then
fi
fi
-AC_SUBST(ENABLE_GDBTK)
AC_SUBST(X_CFLAGS)
AC_SUBST(X_LDFLAGS)
AC_SUBST(X_LIBS)