summaryrefslogtreecommitdiff
path: root/gdb/configure.in
diff options
context:
space:
mode:
authorStan Shebs <shebs@codesourcery.com>1994-12-30 23:42:46 +0000
committerStan Shebs <shebs@codesourcery.com>1994-12-30 23:42:46 +0000
commitd3d75ec97d91fe629105ce3dd96a4cd461561f6e (patch)
tree2cd31fc391f91fa3d793e38065d2a033ab0e4399 /gdb/configure.in
parent227fe4adb9b30d8550849e411a44e82e244698c3 (diff)
downloadbinutils-gdb-d3d75ec97d91fe629105ce3dd96a4cd461561f6e.tar.gz
Sanitize out gdbtk references unless keep-gdbtk specified
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index 29ee96fa16f..0fed66c0a67 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -398,11 +398,13 @@ else
links="${links} nm.h"
fi
+# start-sanitize-gdbtk
# Make it possible to use the GUI without doing a full install
if [ "${enable_gdbtk}" = "yes" -a ! -f gdbtk.tcl ] ; then
files="${files} gdbtk.tcl"
links="${links} gdbtk.tcl"
fi
+# end-sanitize-gdbtk
# post-target:
@@ -420,6 +422,7 @@ if [ "${nativefile}" = "" ] ; then
mv -f Makefile.tem Makefile
fi
+# start-sanitize-gdbtk
if [ "${enable_gdbtk}" = "yes" ] ; then
sed -e '/# End of host and/i\
\
@@ -429,6 +432,7 @@ ENABLE_CLIBS = $(TCL) $(TK) -lX11 -lm
' < Makefile > Makefile.tem
mv -f Makefile.tem Makefile
fi
+# end-sanitize-gdbtk
sed -e '/^TM_FILE[ ]*=/s,^TM_FILE[ ]*=[ ]*,&config/'"${gdb_target_cpu}"'/,
/^XM_FILE[ ]*=/s,^XM_FILE[ ]*=[ ]*,&config/'"${gdb_host_cpu}"'/,