summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorTom Tromey <tom@tromey.com>2019-06-24 16:02:47 -0600
committerTom Tromey <tromey@adacore.com>2019-08-19 10:17:27 -0600
commitd806ea2d0ef362fcddd2c1659f537b68aa114203 (patch)
tree98a15b8aa7aa4a70d552bb115a60a465478f8ec7 /gdb/configure.ac
parentc1a5d03a89a455d79f025c66dce83342de4d26ce (diff)
downloadbinutils-gdb-d806ea2d0ef362fcddd2c1659f537b68aa114203.tar.gz
Add Rust support to source highlighting
Currently, no release of GNU Source Highlight supports Rust. However, I've checked in a patch to do so there, and I plan to make a new release sometime this summer. This patch prepares gdb for that by adding support for Rust to the source highlighting code. Because Source Highlight will throw an exception if the language is unrecognized, this also changes gdb to ignore exceptions here. This will cause gdb to fall back to un-highlighted source text. This updates gdb's configure script to reject the combination of Source Highlight and -static-libstdc++. This is done because it's not possible to use -static-libstdc++ and then catch exceptions from a shared library. Tested with the current and development versions of Source Highlight. gdb/ChangeLog 2019-08-19 Tom Tromey <tom@tromey.com> * configure: Rebuild. * configure.ac: Disallow the combination of -static-libstdc++ and source highlight. * source-cache.c (get_language_name): Handle rust. (source_cache::get_source_lines): Ignore highlighting exceptions.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index 0979109d976..5a18c164057 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -1231,6 +1231,14 @@ if test "${enable_source_highlight}" != "no"; then
AC_MSG_ERROR([pkg-config was not found in your system])
fi
else
+ case "$LDFLAGS" in
+ *static-libstdc*)
+ AC_MSG_ERROR([source highlight is incompatible with -static-libstdc++; dnl
+either use --disable-source-highlight or dnl
+--without-static-standard-libraries])
+ ;;
+ esac
+
if ${pkg_config_prog_path} --exists source-highlight; then
SRCHIGH_CFLAGS=`${pkg_config_prog_path} --cflags source-highlight`
SRCHIGH_LIBS=`${pkg_config_prog_path} --libs source-highlight`