summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorTom Tromey <tom@tromey.com>2019-10-22 16:22:58 -0600
committerTom Tromey <tom@tromey.com>2020-01-14 16:25:02 -0700
commitb2ceabe8f0c2056342834b2b3f52f3b015538df3 (patch)
tree8b4c16a77281523092995fcff85984a7bad6a862 /gdb/configure.ac
parent25c51f71d5bef8b4b71aa3e35cce974b54cda731 (diff)
downloadbinutils-gdb-b2ceabe8f0c2056342834b2b3f52f3b015538df3.tar.gz
Consolidate definition of USE_WIN32API
I noticed that USE_WIN32API is defined separately by gdbserver and gdb. However, because it is used by code in gdbsupport, it should be defined by common.m4. This approach ensures that the code will continue to work when it is moved to the top level. gdb/ChangeLog 2020-01-14 Tom Tromey <tom@tromey.com> * gdbsupport/common.m4 (GDB_AC_COMMON): Define WIN32APILIBS and USE_WIN32API when needed. * configure.ac (USE_WIN32API): Don't define. (WIN32LIBS): Use WIN32APILIBS. * configure: Rebuild. gdb/gdbserver/ChangeLog 2020-01-14 Tom Tromey <tom@tromey.com> * configure.ac (LIBS): Use WIN32APILIBS. (USE_WIN32API): Don't define. * configure: Rebuild. Change-Id: I40d524d5445ebfb452b36f4d0e102f0b1e1089df
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac13
1 files changed, 2 insertions, 11 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index ca0da7980cc..a7b744bf241 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -1827,17 +1827,8 @@ if test x"$gdb_cv_os_cygwin" = xyes; then
fi
# The ser-tcp.c module requires sockets.
-case ${host} in
- *mingw32*)
- AC_DEFINE(USE_WIN32API, 1,
- [Define if we should use the Windows API, instead of the
- POSIX API. On Windows, we use the Windows API when
- building for MinGW, but the POSIX API when building
- for Cygwin.])
- WIN32LIBS="$WIN32LIBS -lws2_32"
- ;;
-esac
-AC_SUBST(WIN32LIBS)
+# Note that WIN32APILIBS is set by GDB_AC_COMMON.
+WIN32LIBS="$WIN32LIBS $WIN32APILIBS"
# Add ELF support to GDB, but only if BFD includes ELF support.
GDB_AC_CHECK_BFD([for ELF support in BFD], gdb_cv_var_elf,