summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorChristian Biesinger <cbiesinger@google.com>2019-10-31 14:41:19 -0500
committerChristian Biesinger <cbiesinger@google.com>2019-10-31 15:14:14 -0500
commitb231e86ac9608056ea837e24d42a878927f5787a (patch)
tree29b98002638e43c04d5a02a23501ea717932c750 /gdb/configure.ac
parenta2726d4ff80168a8134c68cb798e3f5f537b0eba (diff)
downloadbinutils-gdb-b231e86ac9608056ea837e24d42a878927f5787a.tar.gz
Use strerror_r in safe_strerror if available
Also stores the result in a thread-local static variable and changes the return value to a const char*. This is already important because Guile creates threads and Python can create threads, but with the patch series here: https://gnutoolchain-gerrit.osci.io/r/c/binutils-gdb/+/176 GDB itself will create threads, too. gdb/ChangeLog: 2019-10-31 Christian Biesinger <cbiesinger@google.com> * configure: Regenerate. * configure.ac: Check for strerror_r. * gdbsupport/common-utils.h (safe_strerror): Change return value to const char * and document that this function is now threadsafe. * gdbsupport/posix-strerror.c (safe_strerror): Make buf thread_local and call strerror_r, if available. * utils.c (perror_string): Update. (print_sys_errmsg): Update. Change-Id: I81048fbaf148035c221c528727f7efe58ba528eb
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index 354bb7b4b68..987507a17d7 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -1318,7 +1318,7 @@ AC_CHECK_FUNCS([getauxval getrusage getuid getgid \
sigaction sigsetmask socketpair \
ttrace wborder wresize setlocale iconvlist libiconvlist btowc \
setrlimit getrlimit posix_madvise waitpid \
- ptrace64 sigaltstack setns use_default_colors])
+ ptrace64 sigaltstack setns use_default_colors strerror_r])
AM_LANGINFO_CODESET
GDB_AC_COMMON