summaryrefslogtreecommitdiff
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorTom Tromey <tom@tromey.com>2017-11-21 13:17:31 -0700
committerTom Tromey <tom@tromey.com>2017-11-27 16:53:25 -0700
commit8fd8d003de32661ed703ae9fd7e1a856f1b58f81 (patch)
tree397520e3bfcf89a492cf3d2a43fb2d8ed77afe27 /gdb/configure.ac
parentbd810fff78006d38e3c287b7bd241319f4d763be (diff)
downloadbinutils-gdb-8fd8d003de32661ed703ae9fd7e1a856f1b58f81.tar.gz
Move python object files to python subdirectory
Move the object files corresponding to python/*.c to the python subdirectory in the build tree. Because special CFLAGS are passed just to Python compilations, this patch also required the addition of a pattern rule to update INTERNAL_CFLAGS for here. ChangeLog 2017-11-27 Tom Tromey <tom@tromey.com> * Makefile.in (SUBDIR_PYTHON_OBS): Redefine. (CONFIG_SRC_SUBDIR): Add python. (%.o): Remove python rule. (python/%.o): New rule. * configure: Rebuild. * configure.ac (CONFIG_OBS): Refer to python/python.o
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index 00a36be13cf..de24cfa6876 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -1027,7 +1027,7 @@ if test "${have_libpython}" != no; then
else
# Even if Python support is not compiled in, we need to have this file
# included so that the "python" command, et.al., still exists.
- CONFIG_OBS="$CONFIG_OBS python.o"
+ CONFIG_OBS="$CONFIG_OBS python/python.o"
CONFIG_SRCS="$CONFIG_SRCS python/python.c"
fi