summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNathanael Nerode <neroden@gcc.gnu.org>2004-03-24 22:34:31 +0000
committerNathanael Nerode <neroden@gcc.gnu.org>2004-03-24 22:34:31 +0000
commit1a6f2dc7d681432fd0191b59042e8c9db8f8c179 (patch)
treee3680633829eadb2434cbb01a54438c2f610cad2 /configure.in
parent78a1a89446001cbf31afab01607aa6be84a3835d (diff)
downloadbinutils-gdb-1a6f2dc7d681432fd0191b59042e8c9db8f8c179.tar.gz
* configure.in (top level bootstrap support): Rework --enable-werror
to set @stage2_werror_flag@. * configure: Regenerate. * Makefile.tpl (top level bootstrap support): Pass @stage2_werror_flag@ down to configure in stages 2 and 3. * Makefile.in: Regenerate.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 0a9f05fd8fc..5735d84c8b4 100644
--- a/configure.in
+++ b/configure.in
@@ -2129,10 +2129,10 @@ AC_SUBST(stage1_cflags)
AC_ARG_ENABLE(werror,
[ --enable-werror enable -Werror in bootstrap stage2 and later], [],
[enable_werror=yes])
-case ${enable_error} in
- yes) WERROR=-Werror ;;
- *) WERROR= ;;
+case ${enable_werror} in
+ yes) stage2_werror_flag="--enable-werror-always" ;;
+ *) stage2_werror_flag="" ;;
esac
-AC_SUBST(WERROR)
+AC_SUBST(stage2_werror_flag)
AC_OUTPUT(Makefile)