summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCary Coutant <ccoutant@gmail.com>2016-06-29 23:16:24 -0700
committerCary Coutant <ccoutant@gmail.com>2016-06-29 23:16:24 -0700
commit8db8e6948a12faaba4aa5445770b1064ad32e39d (patch)
tree52dbc49ff947efe20925deb711377fc78b36ab39
parent068e05badb9c3802961d67bc90e39c12798e8488 (diff)
downloadbinutils-gdb-8db8e6948a12faaba4aa5445770b1064ad32e39d.tar.gz
Update "make clean" in gold/testsuite.
gold/ * testsuite/Makefile.am (MOSTLYCLEANFILES): Add eh_test_2. * testsuite/Makefile.in: Regenerate.
-rw-r--r--gold/ChangeLog5
-rw-r--r--gold/testsuite/Makefile.am2
-rw-r--r--gold/testsuite/Makefile.in2
3 files changed, 7 insertions, 2 deletions
diff --git a/gold/ChangeLog b/gold/ChangeLog
index 6880b759a1b..5e1fddceca5 100644
--- a/gold/ChangeLog
+++ b/gold/ChangeLog
@@ -1,3 +1,8 @@
+2016-06-29 Cary Coutant <ccoutant@gmail.com>
+
+ * testsuite/Makefile.am (MOSTLYCLEANFILES): Add eh_test_2.
+ * testsuite/Makefile.in: Regenerate.
+
2016-06-30 Alan Modra <amodra@gmail.com>
* testsuite/Makefile.am (memory_test, memory_test_2): Pass
diff --git a/gold/testsuite/Makefile.am b/gold/testsuite/Makefile.am
index b1c671f6129..c8d30934d70 100644
--- a/gold/testsuite/Makefile.am
+++ b/gold/testsuite/Makefile.am
@@ -390,7 +390,7 @@ eh_test: eh_test_a.o eh_test_b.o gcctestdir/ld
check_SCRIPTS += eh_test_2.sh
check_DATA += eh_test_2.sects
-MOSTLYCLEANFILES += eh_test_2.sects
+MOSTLYCLEANFILES += eh_test_2 eh_test_2.sects
eh_test_r.o: eh_test_a.o eh_test_b.o gcctestdir/ld
gcctestdir/ld -r -o $@ eh_test_a.o eh_test_b.o
eh_test_2: eh_test_r.o gcctestdir/ld
diff --git a/gold/testsuite/Makefile.in b/gold/testsuite/Makefile.in
index c28b4f9a243..4185287d03e 100644
--- a/gold/testsuite/Makefile.in
+++ b/gold/testsuite/Makefile.in
@@ -137,7 +137,7 @@ check_PROGRAMS = $(am__EXEEXT_1) $(am__EXEEXT_2) $(am__EXEEXT_3) \
@GCC_TRUE@@NATIVE_LINKER_TRUE@ icf_preemptible_functions_test \
@GCC_TRUE@@NATIVE_LINKER_TRUE@ icf_string_merge_test \
@GCC_TRUE@@NATIVE_LINKER_TRUE@ icf_sht_rel_addend_test \
-@GCC_TRUE@@NATIVE_LINKER_TRUE@ merge_string_literals \
+@GCC_TRUE@@NATIVE_LINKER_TRUE@ merge_string_literals eh_test_2 \
@GCC_TRUE@@NATIVE_LINKER_TRUE@ eh_test_2.sects \
@GCC_TRUE@@NATIVE_LINKER_TRUE@ two_file_shared.dbg \
@GCC_TRUE@@NATIVE_LINKER_TRUE@ alt/weak_undef_lib.so \