summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 050ad147..09c1f597 100644
--- a/configure.ac
+++ b/configure.ac
@@ -785,25 +785,25 @@ AS_IF([test "$THREADS" = posix],
[AC_MSG_CHECKING(for pthread_setname_np)
old_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS $CFLAGS_EXTRA -Werror"
- AC_TRY_LINK([#include <pthread.h>],
- [pthread_setname_np("thread-name")],
+ AC_TRY_COMPILE([#include <pthread.h>],
+ [pthread_setname_np("thread-name")],
[AC_MSG_RESULT([yes (w/o tid)])
AC_DEFINE([HAVE_PTHREAD_SETNAME_NP_WITHOUT_TID], [1],
[Define to use 'pthread_setname_np(const char*)' function.])],
- [AC_TRY_LINK([#include <pthread.h>],
- [pthread_setname_np(pthread_self(), "thread-name-%u", 0)],
+ [AC_TRY_COMPILE([#include <pthread.h>],
+ [pthread_setname_np(pthread_self(), "thread-name-%u", 0)],
[AC_MSG_RESULT([yes (with tid and arg)])
AC_DEFINE([HAVE_PTHREAD_SETNAME_NP_WITH_TID_AND_ARG], [1],
[Define to use 'pthread_setname_np(pthread_t, const char*, void *)'
function.])],
- [AC_TRY_LINK([
+ [AC_TRY_COMPILE([
#ifdef __CYGWIN__
#define _GNU_SOURCE 1
#elif defined(__linux__) || defined(__GLIBC__) || defined(__GNU__)
#define _GNU_SOURCE 1
#endif
#include <pthread.h>],
- [pthread_setname_np(pthread_self(), "thread-name")],
+ [pthread_setname_np(pthread_self(), "thread-name")],
[AC_MSG_RESULT([yes (with tid)])
AC_DEFINE([HAVE_PTHREAD_SETNAME_NP_WITH_TID], [1],
[Define to use 'pthread_setname_np(pthread_t, const char*)'