summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2012-02-09 20:27:45 +0400
committerIvan Maidanski <ivmai@mail.ru>2012-02-09 20:27:45 +0400
commit4d972fa5f3f9d2e3e093285df4285c592d88e3fa (patch)
treeb171c74a7abcd0afb720acb86a897b0350147817 /configure.ac
parent1115b9a9eadf27b4db1cdf6f84957d18638faecf (diff)
downloadbdwgc-4d972fa5f3f9d2e3e093285df4285c592d88e3fa.tar.gz
Update TODO (failure in Cygwin resolved)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bdaf215e..c48daa0c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -785,6 +785,14 @@ AC_ARG_ENABLE(munmap,
if test "${enable_munmap}" != ""; then
AC_DEFINE([USE_MMAP], 1,
[Define to use mmap instead of sbrk to expand the heap.])
+ case "$host" in
+ *-*-cygwin*)
+ # Workaround for Cygwin: use VirtualAlloc since mmap(PROT_NONE) fails
+ AC_DEFINE([USE_WINALLOC], 1,
+ [Define to use Win32 VirtualAlloc (instead of sbrk or \
+ mmap) to expand the heap.])
+ ;;
+ esac
AC_DEFINE([USE_MUNMAP], 1,
[Define to return memory to OS with munmap calls
(see doc/README.macros).])