summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCalvin <calvin@cmpct.info>2017-12-06 16:43:20 -0400
committerIvan Maidanski <ivmai@mail.ru>2018-01-22 21:12:32 +0300
commite52f30024f9e7722a00ac863a3c00ba0de459e4d (patch)
tree53b2d626812a42759b81d45c124243d6a5d376e2 /configure.ac
parent5d819c884576d8c5f5f117f010efd49696bd81f8 (diff)
downloadbdwgc-e52f30024f9e7722a00ac863a3c00ba0de459e4d.tar.gz
Compile on amd64 Haiku (#4473)
* Compile on amd64 Haiku Use sigcontext (somewhat like win32, or x86) on Haiku amd64. On amd64, Haiku doesn't have issues with marshalling 64-bit values, but it currently does have issues with SGen either causing a stall or a core dump. As such, while it can compile the stdlib (further than x86 got), it's still a work in progress. * Use set_real_time_clock for sys-time.c on Haiku * Get mono-boehm compiling on Haiku again It still doesn't work. Initialization will call GC_mark_from, which will cause a segmentation fault as it decrements pointers. (Mono will enter an infinite loop in mono_get_hazardous_pointer as a result.) For now, mono-sgen will continue to be used by default.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7f5aa031..628144d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -104,6 +104,10 @@ case "$THREADS" in
AC_DEFINE(GC_AIX_THREADS)
AC_DEFINE(_REENTRANT)
;;
+ *-*-haiku*)
+ AC_DEFINE(GC_HAIKU_THREADS)
+ AC_DEFINE(_REENTRANT)
+ ;;
*-*-hpux*)
AC_MSG_WARN("Only HP/UX 11 threads are supported.")
AC_DEFINE(GC_HPUX_THREADS)