summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlex Ronne Petersen <alexrp@xamarin.com>2016-04-07 08:37:30 +0200
committerIvan Maidanski <ivmai@mail.ru>2016-06-02 00:34:52 +0300
commitaabc230c4753d7504e8e64a41bcbb4e7c386d9fe (patch)
treec13050e245bc8b75e1983b25f897fa2d6a893d39 /configure.ac
parent02ec857444143a74a8624637c149634cb56bb7c6 (diff)
downloadbdwgc-aabc230c4753d7504e8e64a41bcbb4e7c386d9fe.tar.gz
Fix broken AC_TRY_COMPILE() invocation in configure.ac.
Fixes: https://bugzilla.xamarin.com/show_bug.cgi?id=40144 Tested on PowerPC by Mathieu Malaterre <malat@debian.org>.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index ac992abf..7f5aa031 100644
--- a/configure.ac
+++ b/configure.ac
@@ -233,10 +233,8 @@ AM_CONDITIONAL(POWERPC_DARWIN,test x$powerpc_darwin = xtrue)
AC_MSG_CHECKING(for __sync_bool_compare_and_swap)
AC_TRY_COMPILE([],[
volatile unsigned int foo = 0;
-int main(int argc, char** argv) {
- unsigned int r1 = __sync_bool_compare_and_swap(&foo, 0, 1);
- return 0;
-}
+unsigned int r1 = __sync_bool_compare_and_swap(&foo, 0, 1);
+return 0;
], [
AC_MSG_RESULT(yes)
AC_DEFINE(HAS___SYNC_BOOL_COMPARE_AND_SWAP)