summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIvan Maidanski <ivmai@mail.ru>2018-05-18 22:00:36 +0300
committerIvan Maidanski <ivmai@mail.ru>2018-05-18 22:00:36 +0300
commit658f6393ffa12798c1cacfa3fa688247289e8544 (patch)
tree9ee90142d83e0efd07ca45dee3777ded198c9341 /configure.ac
parenta043dadec3c3f97e5899cf7d81e8f0dea9a347de (diff)
downloadbdwgc-658f6393ffa12798c1cacfa3fa688247289e8544.tar.gz
Do not use PKG_CHECK_MODULES in configure
Issue #200 (bdwgc). Presence of libatomic_ops is now detected only by checking the installed headers, but libatomic_ops is no longer needed for most of the clients which have atomic intrinsics support by the compiler. * README.md (Installation and Portability): Remove information about "syntax error near unexpected token ATOMIC_OPS". * autogen.sh: Update comment removing pkg-config from the requirements. * configure.ac (PKG_CHECK_MODULES(ATOMIC_OPS)): Comment out; update the comment.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 501be32d..3170309d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1018,13 +1018,12 @@ missing_libatomic_ops=false
AS_IF([test x"$with_libatomic_ops" != xno -a x"$with_libatomic_ops" != xnone],
[ missing_libatomic_ops=true ])
-dnl Note: "syntax error near unexpected token ATOMIC_OPS" reported by configure
-dnl means Autotools pkg.m4 file was not found during aclocal.m4 generation;
-dnl in this case, most probably, you should run pkg-config once before running
-dnl autogen.sh (autoreconf); alternatively, comment out the following 3 lines.
-AS_IF([test x$missing_libatomic_ops = xtrue],
- [ PKG_CHECK_MODULES([ATOMIC_OPS], [atomic_ops],
- [ missing_libatomic_ops=false ], [ [] ]) ])
+dnl To avoid "syntax error near unexpected token ATOMIC_OPS" configure error
+dnl observed by some clients, the following 3 code lines are commented out:
+dnl
+dnl AS_IF([test x$missing_libatomic_ops = xtrue],
+dnl [ PKG_CHECK_MODULES([ATOMIC_OPS], [atomic_ops],
+dnl [ missing_libatomic_ops=false ], [ [] ]) ])
dnl Retry with AC_CHECK_HEADER if PKG_CHECK_MODULES failed.
AS_IF([test x$missing_libatomic_ops = xtrue],