summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPetter Urkedal <paurkedal@gmail.com>2011-08-14 12:57:27 +0200
committerPetter Urkedal <paurkedal@gmail.com>2011-08-14 13:10:40 +0200
commit4ea4917ccf99952726ac141fb6317368437b93f2 (patch)
treebe0775d33335a368c57f05f29dbe27407e27cc7a /Makefile.am
parentcc71a44e2736bac577673feb20ee66841d34ec92 (diff)
downloadbdwgc-4ea4917ccf99952726ac141fb6317368437b93f2.tar.gz
Use pkg-config to pick up libatomic_ops, etc.
* configure.ac: Remove checks for ar and ranlib. * configure.ac: Replace AC_CHECK_HEADER with PKG_CHECK_MODULES when checking for libatomic_ops. The macro sets the appropriate flags, so simplify accordingly. * Makefile.am, configure.ac: Set ATOMIC_OPS_CFLAGS in configure.ac instead of conditionally doing it in Makefile.am, to be more consistent with the pkg-config case. * configure.ac: Fix a typo and some phrases.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index ac394484..f652c723 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,11 +33,9 @@
SUBDIRS =
ACLOCAL_AMFLAGS = -I m4
-AM_CPPFLAGS = -I$(top_builddir)/include -I$(top_srcdir)/include
-if USE_INTERNAL_LIBATOMIC_OPS
-AM_CPPFLAGS += -I$(top_builddir)/libatomic_ops/src \
- -I$(top_srcdir)/libatomic_ops/src
-endif
+AM_CPPFLAGS = \
+ -I$(top_builddir)/include -I$(top_srcdir)/include \
+ $(ATOMIC_OPS_CFLAGS)
# Initialize variables so that we can declare files locally.
EXTRA_DIST =