summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorhboehm <hboehm>2007-05-24 00:23:26 +0000
committerIvan Maidanski <ivmai@mail.ru>2011-07-26 21:06:40 +0400
commitf8d93569561f9fc0ef2fc0cf78c964bd9f292d1a (patch)
tree883fe1d1544477e99b55a64db816b1f961c3cfb3 /Makefile.am
parent5b2bf5e73f74ae8a99af990ef6950560d8f3d6f4 (diff)
downloadbdwgc-f8d93569561f9fc0ef2fc0cf78c964bd9f292d1a.tar.gz
2007-05-23 Hans Boehm <Hans.Boehm@hp.com>
* Makefile.am: Move includes to bottom. Add better library dependencies. Increment library version. Remove "SUBDIRS += .". * cord/cord.am, tests/tests.am: Add better library dependencies. Remove now unnecessary dependencies. * Makefile.in: Regenerate. * include/gc.h (GC_begin_thread_ex, GC_endthreadex, GC_ExitThread): Move to define on all Windows platforms. (_beginthread): define to generate error if used.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 13 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index a842c7ac..648e0405 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,8 +32,6 @@
# endif
SUBDIRS =
-SUBDIRS += .
-
# Initialize variables so that we can declare files locally.
EXTRA_DIST =
lib_LTLIBRARIES =
@@ -46,12 +44,6 @@ TESTS =
pkgconfigdir = $(libdir)/pkgconfig
dist_pkgconfig_DATA = bdw-gc.pc
-include include/include.am
-include cord/cord.am
-include tests/tests.am
-include doc/doc.am
-
-
# C Library
# ---------
@@ -91,7 +83,8 @@ endif
# linuxthread semaphore functions get linked:
libgc_la_LIBADD = @addobjs@ $(THREADDLLIBS) $(UNWINDLIBS)
libgc_la_DEPENDENCIES = @addobjs@
-libgc_la_LDFLAGS = $(extra_ldflags_libgc) -version-info 1:2:0
+libgc_la_LDFLAGS = $(extra_ldflags_libgc) -version-info 1:3:0
+# -no-undefined doesn't work here, since we get a reference to __tls_get_addr.
EXTRA_libgc_la_SOURCES = alpha_mach_dep.S \
mips_sgi_mach_dep.s mips_ultrix_mach_dep.s \
@@ -106,8 +99,8 @@ if CPLUSPLUS
lib_LTLIBRARIES += libgccpp.la
pkginclude_HEADERS += include/gc_cpp.h include/gc_allocator.h
libgccpp_la_SOURCES = gc_cpp.cc
-libgccpp_la_LIBADD = $(THREADDLLIBS) $(UNWINDLIBS)
-libgccpp_la_LDFLAGS = -version-info 1:2:0
+libgccpp_la_LIBADD = $(top_builddir)/libgc.la
+libgccpp_la_LDFLAGS = -version-info 1:3:0 -no-undefined
endif
# FIXME: If Visual C++ users use Makefile.am, this should go into
@@ -203,3 +196,12 @@ EXTRA_DIST += libtool.m4
# it will not remove dest if building fails
.S.s:
if $(CPP) $< >$@ ; then :; else rm -f $@; fi
+
+include include/include.am
+include cord/cord.am
+include tests/tests.am
+include doc/doc.am
+# Putting these at the top causes cord to be built first, and not find libgc.a
+# on HP/UX. There may be a better fix.
+
+