summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Paleino <dapal@debian.org>2011-05-02 17:01:23 +0200
committerDavid Paleino <dapal@debian.org>2011-05-02 17:01:23 +0200
commit5961c3b8cdeebb8d0f2238970490cdc0d9b26c36 (patch)
tree59684e3f7f6a7773d64ea53efdd7c16d30e17b3a /Makefile.am
parentb25abe601daf622cd6957d2f07383a4c71e3a01b (diff)
downloadbash-completion-5961c3b8cdeebb8d0f2238970490cdc0d9b26c36.tar.gz
Layout change: everything is now in /usr/share/bash-completion/, rather than in /etc/.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 6550a83d..a41181d6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,12 +1,12 @@
SUBDIRS = completions test
-sysconf_DATA = bash_completion
+data_DATA = bash_completion
profiledir = $(sysconfdir)/profile.d
profile_DATA = bash_completion.sh
bash_completion.sh: bash_completion.sh.in Makefile
- sed -e 's|@sysconfdir[@]|$(sysconfdir)|' <$(srcdir)/$@.in >$@
+ sed -e 's|@datadir[@]|$(datadir)|' <$(srcdir)/$@.in >$@
CLEANFILES = bash_completion.sh
@@ -14,6 +14,7 @@ EXTRA_DIST = CHANGES $(sysconf_DATA) bash_completion.sh.in
install-data-hook:
tmpfile=`mktemp $${TMPDIR:-/tmp}/bash_completion.XXXXXX` && \
- sed -e 's|=/etc/bash_completion|=$(sysconfdir)/bash_completion|' \
- $(DESTDIR)$(sysconfdir)/bash_completion > $$tmpfile && \
- mv $$tmpfile $(DESTDIR)$(sysconfdir)/bash_completion
+ sed -e 's|=/usr/share/bash-completion/|=$(datadir)/|' \
+ -e 's|=/etc/bash_completion|=$(sysconfdir)/bash_completion|' \
+ $(DESTDIR)$(datadir)/bash_completion > $$tmpfile && \
+ mv $$tmpfile $(DESTDIR)$(datadir)/bash_completion